Login    Forum    Search    FAQ

Board index » Questions and Answers




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 24 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post Posted: Tue Jun 25, 2013 10:33 am 
Offline
User avatar

Joined: Fri Jun 21, 2013 8:01 pm
Posts: 147
Question

“I received the excavator and have no idea where to put the “Punch Plate” and “Hog Moss”

Answer

Install the matting. Put in the Hog Moss over the mat at the top of the sluice under the header box. Install the “Punch Plate” over the Hog Moss with the angle facing downstream.

The first part of this video shows you.



Top 
 Profile  
 
 Post Posted: Tue Jun 25, 2013 10:35 am 
Offline
User avatar

Joined: Fri Jun 21, 2013 8:01 pm
Posts: 147
Question

Is there a flare available for the Excavator extension in case you would like to run the extension as a stream sluice?

Answer

No.

Also the matting used in the Excavator would not be recommended for use in a stream sluice.


Top 
 Profile  
 
 Post Posted: Tue Jun 25, 2013 11:50 am 
Offline
User avatar

Joined: Fri Jun 21, 2013 8:01 pm
Posts: 147
Question

"I just received my 2.5 H.P. pump you recommended. I did not use the plastic hose fittings that came with it. My 1-1/2” lay flat hose and my 1-1/2” pump suction hose are not sealing properly to the pump suction and discharge. What can I do?"

Answer

Simple solution.

Most, but not all of the Chinese 2.5 HP pumps have this problem if you don't use the plastic hose fittings that come with it. This usually happens if you are using the standard U.S. 1-1/2" brass hose fittings that are available. Just double up on your rubber 1-1/2” hose gaskets. Put two gaskets in the fitting and they seal it perfectly. You may want to add a drop of Gorilla super glue between the two gaskets so they are always together and the additional gasket won’t fall out and get lost.


Top 
 Profile  
 
 Post Posted: Tue Jun 25, 2013 12:27 pm 
Offline
User avatar

Joined: Fri Jun 21, 2013 8:01 pm
Posts: 147
Question

"You said the 2.5 HP pump is “Self Priming”. I’ve tried to read and understand the manual that comes with the pump, but the way it is written it’s next to impossible to understand it. How do I prime this pump?"

Answer

Remove the cap from the priming port at the top of the pump casing and fill the pump casing with water until you see it overflowing into the discharge hose. Re-install the priming port cap and start your engine. You should gradually see water “Walking” up your suction hose into the pump. Shortly afterwards your pump should be discharging water from the discharge hose.

Attachment:
Priming Port Cap.jpg
Priming Port Cap.jpg [ 77.21 KiB | Viewed 1951 times ]


If your pump fails to draw a suction shut it off immediately and check for air leaks on the suction hose fitting and suction hose. Check to make sure your suction hose strainer is under water also.

Never run your pump with a dry pump casing.
Never use a lay flat hose as a pump suction hose.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 24 posts ]  Go to page Previous  1, 2, 3

Board index » Questions and Answers


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron